Bacom AVR- program nie startuje

To forum jest dla wszystkich pasjonatów mikrokontrolerów AVR Atmela. Wymiana doświadczeń i pomoc dla początkujących w pisaniu programów zarówno w C, Asemblerze jak i BASCOM. Zapraszam znawców tematu, aby pomogli wszystkim początkującym!
ODPOWIEDZ
maxxxior
Użytkownik
Posty: 210
Rejestracja: 19 mar 2010, 21:27
Lokalizacja: Skierniewice

Bacom AVR- program nie startuje

Post autor: maxxxior » 04 lis 2014, 15:07

Witam
Programuję już trochę w C, ale ostatnio znalazłem ciekawy projekcik w Bascomie i chciałem go sobie zmontować. programator jaki posiadam to USBASP, a mikrokotroler Atmega8. Na początek podpiąłem tylko diodę do jednego pinu uC, i napisałem prosty programik żeby nią zamigać. Program niby się wgrywa, ale dioda nie miga. Czy coś trzeba wgrywać próćz Bascom-AVR? Jakieś wtyczki? Jakieś ustawienia w programie trzeba zmieniać? Podłączenie jest dobre ponieważ MkAVRCalculator normalnie wykrywa procesor.
oto kod:

Kod: Zaznacz cały

$regfile = "m8def.dat"
$crystal = 1000000

Config Portc = Output
        Portc = &B00000000

Do
 Portc.1 = 1
Waitms 1000
 Portc.1 = 0
Loop

End
Po wgraniu programu w ogóle nie ma żadnej zmiany napięcia na PC1. Wygląda na to że program się w ogóle nie wgrywa, albo czegoś nie poustawiałem w programie :/

maxxxior
Użytkownik
Posty: 210
Rejestracja: 19 mar 2010, 21:27
Lokalizacja: Skierniewice

Post autor: maxxxior » 04 lis 2014, 19:43

Ok, problem rozwiązany. Okazał się że miałem jakiegoś starego Bascom-AVR i nie chciał poprawnie wgrywać programu do uP. Zainstalowanie wersji 2.0.7.3 rozwiązało sprawę i wszystko już działa jak należy.
Temat do zamknięcia.

ODPOWIEDZ